Temporary disturbances
Incident Report for Slaask
Resolved
This incident has been resolved.
Posted 7 months ago. Sep 07, 2018 - 15:22 CEST
Identified
We are updating the app. Temporary disturbances can occur for a few seconds.
Posted 7 months ago. Sep 07, 2018 - 15:09 CEST
This incident affected: Slaask Widgets.