Some issues with our login page
Incident Report for Slaask
Resolved
We are glad to let you know that this issue is now resolved. You may still be facing some slowdowns in the next few minutes. Thank you for your support! Have a great day!
Posted Jun 23, 2020 - 11:07 CEST
Update
We are currently deploying additional servers. Situation should be back to normal very soon. Thanks
Posted Jun 23, 2020 - 10:39 CEST
Monitoring
The issue has been identified and a fix is being implemented.
Posted Jun 23, 2020 - 10:03 CEST
This incident affected: Slaask Web App (slaask.com).