Service disruption
Incident Report for Slaask
Resolved
This incident has been resolved. You can welcome your new Inbox! :D
Posted Feb 13, 2020 - 13:41 CET
Investigating
We are currently investigating this issue.
Posted Feb 13, 2020 - 13:19 CET
This incident affected: Slaask Web App (slaask.com).