We identified an issue with non English users
Incident Report for Slaask
Resolved
This incident is now resolved. Thank you for your patience.
Posted 7 months ago. Dec 17, 2018 - 17:14 CET
Identified
We identified an issue with non English users. This issue should be fixed in 30-60 minutes from now.
Posted 7 months ago. Dec 17, 2018 - 16:16 CET
This incident affected: Slaask Widgets.