We are experiencing slowdowns
Incident Report for Slaask
Resolved
This incident has been resolved. Thank you
Posted Oct 06, 2021 - 15:31 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 06, 2021 - 15:02 CEST
This incident affected: Slaask Web App (slaask.com).